Author Topic: Pump Maintenance  (Read 1160 times)

0 Members and 1 Guest are viewing this topic.

Offline misterflask

Pump Maintenance
« on: March 08, 2013, 08:10:11 am »
I have a recurring problem with pump maintenance on my 0-ring sealed pumps (currently w/ road morphG, but also w/ other pumps).  After a year or two of use (mainly being carried around), my pumps lose efficiency or quit working.  They've been thoroughly cleaned and inspected and I can see nothing wrong. After a good clean and lube they get better but never reclaim their new efficiency.  After a recent cleaning, I lubed the pump with some high quality turbine oil, which prevented it from working at all.  My conclusion was that the o-ring has to generate enough friction to seat itself.  I replaced the turbine oil with some sticky chainsaw bar-lube, which made the pump work, but not at its new efficiency. 

Does anyone have a secret for keeping pumps at top efficiency over the long term?

Offline bogiesan

Re: Pump Maintenance
« Reply #1 on: March 08, 2013, 09:05:14 am »
There are two surfaces the o-ring must mate with perfectly: the slot in the pump's plunger and the inner surface of the pump's tube. Shining a light down the tube should reveal major imperfections or flaws. You will probably need a magnifying glass to check the slot. Guessing the o-ring is slightly too large and will not seat propelry against the plunger. Could be worn or just the wrong size. Many hardware stores stock a wide selection of precision o-rings.

I've had a modern Topeak RoadMorph pump fail once and the o-ring had completely disintgrated; it just flaked off. The Topeak o-rings in stock at my LBS did not quite fit--slightly too large. It was time to get a new pump anyway.

My floor pump is an old Italian unit for which I can still buy parts made of solid brass. The plunger relies on a leather cup that is now about 30 years old. I use a few drops of light oil on it every spring.
I play go. I use Macintosh. Of course I ride a recumbent

Offline johnsondasw

Re: Pump Maintenance
« Reply #2 on: March 08, 2013, 08:59:01 pm »
I've had the same issues on pumps--they last at best abouit 2-3 years and then start leaking air out while trying to get adequate pressure.  I've also never been able to get them back to good. and just end up buying new ones.
May the wind be at your back!

Offline misterflask

Re: Pump Maintenance
« Reply #3 on: March 23, 2013, 09:10:56 am »
Here's how this turned out.  A polite email to Topeak customer support yielded a supply of barrel o-rings and replacing the o-ring immediately restored the pump to like-new performance (woo-hoo). 

Careful examination of the old o-ring found it about .004" undersize in crossection and there were some very small tears in the sealing surface visible under 30x.  I had assumed that there would have been either a large amount of wear degradation or swelling, but the old o-ring had enough dimensional integrity to have sized a replacement (I believe a 2.4x17.3mm available at o-rings.com).  I had originally been thrown off by the normal practice in o-ring world of sizing the o-ring by the barrel and groove sizes, but that approach did not yield anything close. 

I read that Buna-n (the most likely material) is susceptible to atmospheric degradation, particularly from ozone.  Might explain why my pumps always fail after a year-or-so of urban commuter riding, even with little use. 

Last note- barrel corrosion and all that loose aluminum oxide seems to be a contributor the problem.  The pump handle on the roadmorph latches securely so I now carry it upside down to keep rain out of the barrel.

Offline DaveB

Re: Pump Maintenance
« Reply #4 on: March 23, 2013, 09:34:53 am »
Nice to hear Topeak supported their product. I expect that rain and splashed water causes the death of most frame mounted pumps.  They are exposed to the elements on every ride but used infrequently (unless you are VERY unlucky) so the water that gets inside sits there undisturbed and you only find out when the pump fails when you really need it.

I've had two Blackburn pumps fail to work and later found the ball checks were rusted into uselessness.  Blackburn  replaced them under warranty but now I test my pumps frequently so I get the bad news when it doesn't count.